Loading...
 

BTSensor Calibration Settings

After BTSensors are placed and orientated with overlapping views around the Space, BlackTrax requires that all BTSensors be calibrated. Calibration enables BlackTrax to know BTSensor positions relative to each other and the floor. This spatial awareness of the Space is required for tracking to be accurate. Before BTSensor calibration can occur, certain settings in Motive must be configured.

Motive 2

In Motive, calibration data for each BTSensor position, orientation and lens parameters are saved as standalone calibration CAL (.cal) file format which can be exported to a desired location for later use. See To export a calibration CAL file below.

Motive can be set for Continuous Calibration where the system continuously monitors BTSensor movements and readjusts the BTSensor calibration accordingly. See  To configure Motive for continuous calibration below.

To configure BTSensors for calibration

  1. In Motive, change the layout to Calibration preset. From the Layout menu, choose Calibration.
    • Tip: You may click the drop-down box at the right-hand side of the main toolbar and click Calibration from the drop-down menu of layout presets.
  2. Go to the Devices window.
    • Note: To quickly configure a BTSensor for calibration, change the preset setting of the BTSensor to Tracking then proceed to Step 7 in this section.
  3. In the Devices window, select the camera group by clicking on the group name.                                  DevicesGroup CameraSettings  
  4. While the sensor group is still selected, click the Properties section for the sensor group.
  5. Click the Camera Settings section and set the Video Type field to Object Mode for tracking and calibration.
  6. Set the Filter Switch field to Visible Spectrum.
  7. Go to the Application Settings window and click the Live Reconstruction tab.
  8. On the Live Reconstruction tab, click the Marker Labelling Mode drop-down box and select Active and Passive Markers or Passive Markers Only to set for calibration.                                           ApplicationSettings MarkerLabellingMode  
  • Note: Select Active Markers Only or Active and Passive Markers to set for tracking.    

To configure Motive for continuous calibration

BTSensors must have already been calibrated if Continuous Calibration will be used.

  1. In the Calibration preset layout, go to the Application Settings window.
  2. On the Application Settings window, click the Live Reconstruction tab.
  3. On the Live Reconstruction tab, click Continuous Calibration.
  4. On the Continuous Calibration drop-down menu, select Continuous.
    • Result: Motive will continuously monitor and update the BTSensor calibration.

To export a calibration CAL file

  1. In the Calibration preset layout, click the File menu.
  2. From the File menu, choose Export Camera Calibration.
    • Result: The Export Camera Calibration window appears.
  3. Navigate to the location where the calibration file will be saved.
  4. In the File name field, type the name of the calibration .cal file.
  5. Click the Export button.
    • Result: The calibration results are preserved as a .cal file which can be loaded into Motive.

To open and restore a calibration CAL file

  1. In Motive, from the File menu, choose Open.
    • Result: The Open window appears.
  2. Navigate and select the .cal file you wish to open and restore.
  3. Click Open.
    • Result: The saved calibration data will be restored in Motive.

Motive 1.10 or lower

To configure BTSensors for calibration

  1. Change the Motive layout to Calibration (found under Layout > Calibration).
  2. Go to the Cameras window.
    • Note: To quickly configure a BTSensor for calibration, change the preset setting of the BTSensor to Tracking, then proceed to Step 6 in this section. 
  3. In the Cameras window, select the sensor group by clicking on the group name.                   Camera Pane Blacked Out   
  4. While the sensor group is still selected, look below to the Property section for the sensor group. Under the Camera Settings heading, set the Video Type field to Precision Mode/Object Mode.
  5. Set the Filter Type Switch field to Infrared Spectrum.
  6. Go to the Application Settings window.
  7. In the Application Settings window, in the Options tab, under the Application Options heading, set the Active Marker Labeling field to False.                                                                         Active Marker Labeling  
  8. Close the Application Settings window.